Aviary web widget v3 now out of beta!

web_landing

The new and improved v3.0 of our Web Editor is officially available, so you can update your integration at any time. It looks beautiful, includes some awesome new features, and runs more smoothly than ever! For instructions on updating and details about how long you have before it becomes the default for all partners, read on.

v3 Highlights

  • Gorgeous, streamlined interface: better customization for you, and improved performance for your users
  • Improved a number of tools, including Enhance, Crop, Draw, and Text
  • Improved the top and bottom toolbars of the editor: tool name displayed above, image size below the photo
  • Removed last page (feedback/get this editor) from top toolbar
  • Greatly improved general performance and responsiveness
  • Note: We are officially dropping support for IE7. It's less than 1% of our web usage, and after talking to a sample of our partners it seems like most of you are dropping IE7 as well. If you still require support for IE7, get in touch and we can discuss your options.

How to Update!

  1. API Keys As of v3, API keys are now required. If you don't have one yet, you can grab one from aviary.com/web.

  2. Feather.js URL Make sure you're using the url http://feather.aviary.com/js/feather.js for your integration. As of September, no other urls will be accepted, so you will be forced onto this version even if you've been pointing to an outdated url previously. You can also use our code generator to grab the full web widget code, which comes with a couple theme options and works straight out of the box!

  3. apiVersion Number When you're ready to update to the new version, change the apiVersion configuration parameter to 3. As of today, this will work immediately on production. (It is also now the new default value for apiVersion, so if you are not currently specifying an apiVersion and want to remain on v2 for a bit, be sure to set apiVersion to 2!) Note: On September 16th, version 2 will be deprecated and apiVersion will be forced to 3 for all integrations. If you're currently doing anything anything unsupported, make sure you test your custom CSS and update to v3 before you are forced into it in September! See our Timeline below for instructions for staying on v2 past that date.

  4. Customization Start with the dark or light default theme and customize the editor from there. If you're currently doing anything anything unsupported with CSS we highly recommend removing any existing customization and starting fresh with the new version (this should be much easier than tweaking existing code - a lot has changed!). If you have any questions or concerns about achieving a certain look for your integration, don't hesitate to get in touch.

  5. minimumStyling If you'd like to take it one step further and build your own theme for the editor, you can use the minimumStyling configuration with either the dark or light theme. That said, we highly recommend building on top of one of our default themes, as those come with built in transitions, hover states, etc - try them out, they feel really nice!

Timeline

  • Today, July 15th: v3 is officially available. The apiVersion parameter will default to 3 if it isn't specified. To remain on v2 past this date, make sure to set apiVersion to 2.
  • September 16th: v2 will be deprecated entirely. Hardcoded apiVersion numbers (as well as any url besides http://feather.aviary.com/js/feather.js) will no longer be valid and will be overridden with these defaults. If you need to stay on v2 or a custom url past this date please contact us.

We hope you love this new editor as much as we do, and we're looking forward to hearing your feedback!

Cheers, Aviary